Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-35007

Cannot find elements when using Ranorex UI test tool.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Not Evaluated
    • Resolution: Done
    • Affects Version/s: 4.8.4
    • Fix Version/s: 5.1.1
    • Labels:
      None
    • Environment:
      Windows7, Visual Studio v2010, c++.

      Description

      When I use Ranorex (a Windows test tool) to track the UI component written using Qt for C++ I cannot see the elements. I have included two images of the Ranorex Spy tool tracking some components of the qtDemo=>Config Dialog example for both Qt-4.6.3 and Qt-4.8.4. How you can see from Ranorex-Spy-with-qt.4.6.3-finding-elements.png image I can find the elements in the qt-4.6.3 qtDemo=>Config Dialog example. On the contrary the Ranorex-Spy-with-qt.4.8.4-not-finding-elements.png image shows that I cannot find the element with the same qtdemo =>Config Dialog example in qt-4.8.4.

      We use QT Accessibility with Ranorex to track the components of our application and we just moved from Qt-4.6.3 (which we could see the elements) to Qt-4.8.4 where we cannot see the elements any more.

      Is this a bug or just Qt is moving away from this?

      Thanks
      Mauro Fanton

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            frederik Frederik Gladhorn
            Reporter:
            mfanton Mauro Fanton
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes