Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-35658

XCB/XFCE 4.10: QSystemTrayIcon doesn't show or do anything

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Done
    • Affects Version/s: 5.2.0
    • Fix Version/s: 5.4.2, 5.5.0 Alpha
    • Labels:
      None
    • Environment:
      Arch Linux x64, XFCE 4.10
    • Commits:
      612953a626ec21b8518ee23a4f5268b566cf41e5 2203d9d93e24e00d6e9bc9bda0e65a0c7f9923cc 0eefa785a0d8bfe96403f9c13e80544cf8bb8eb3 98aae7428d86155a596c4318643752477d7726ad

      Description

      After starting the systray example I don't see a systray icon and the button "Show message" has no effect either.
      I have two other programs, where the systray icon doesn't show either.

      QSystemTrayIcon::isSystemTrayAvailable() and QSystemTrayIcon::supportsMessages() return true.
      Under Qt 4.8.5 it works as expected.

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              • Assignee:
                srutledg Shawn Rutledge
                Reporter:
                mkrems Marcel Krems
              • Votes:
                2 Vote for this issue
                Watchers:
                12 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: