Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-35756

Webkit/QTextEdit input broken for IME input of Japanese, Korean, etc.

    XMLWordPrintable

    Details

      Description

      Blinking text cursor is misplaced when writing japanese.
      Cursor is moved all the time to the beginning of the line. Letters are still drawn correctly to the end of the line.

      To reproduce issue do following:

      Enable Japanese IME:
      'Control Panel' -> Region and Language' -> 'Keyboards and Languages' -> 'Change keyboards' -> "Add.." -> "Japanese:Microsoft IME" -> "OK" -> "Language Bar" -> "Floating On Desktop"

      Load page below with Qt fancybrowser set cursor in the input box.
      Change to Japanese from Language Bar and set the input mode to 'Hiragana' and Conversion mode to 'General'.

      page.html
      <!DOCTYPE html>
      <html>
      <head>
      <title>IME Test</title>
      </head>
      <body>
      <input type="text" value=""></input>
      </body>
      </html>
      

      Write some Japanese. For example writing 'moderu' and you can see cursor is moved to the beginning of the edit box.

      Test same with Chrome and cursor is correctly end of the text all the time.

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              mibrunin Michael Bruning
              Reporter:
              qtcomsupport Qt Support
              Votes:
              6 Vote for this issue
              Watchers:
              9 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes