Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-36268

QWidget doesn't become active after losing it to a QDialog that contains a QGLWidget...

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P3: Somewhat important
    • Resolution: Fixed
    • Affects Version/s: 5.2.0
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      Qt 5.2.0 running on a 10.9.1 Mac Book Pro (late 2011).
    • Platform/s:
      macOS

      Description

      I have a QWidget window with QToolButtons in it. I then create manually create a QDialog that includes a manually created Okay button and a manually created QGLWidget. When I click the okay button, its clicked signal is received by the dialog's accept slot. The dialog disappears, returning the Accepted enum. However, the QWidget window does not become active even though it is the only open window. I've created a test project includes as an attachment that shows the issue running on my Mac Book Pro 10.9.1

        Attachments

        1. DialogError.pro
          0.3 kB
        2. main.cpp
          0.2 kB
        3. testwidget.cpp
          1 kB
        4. testwidget.h
          0.6 kB
        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            tpochep Timur Pocheptsov
            Reporter:
            drhalftone Daniel Lau
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes