Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-36642

Support XML Schema 1.1

    XMLWordPrintable

    Details

    • Type: Suggestion
    • Status: Reported
    • Priority: P2: Important
    • Resolution: Unresolved
    • Affects Version/s: 5.2.0
    • Fix Version/s: None
    • Component/s: XML: QtXmlPatterns
    • Labels:
      None

      Description

      Currently Qt supports XML schema specification 1.0 only. Since two years version 1.1 is officially recommended. It brings a lot of improvements that I would like to be able to use in Qt. Currently the feature that I am missing most are co-constraints (see http://www.w3.org/wiki/Co-constraint_Use_Cases).

      Please enable QXmlSchemaValidator to support 1.1 schemas.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              silicomancer Bernhard Lindner
            • Votes:
              7 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:

                Gerrit Reviews

                There are no open Gerrit changes