Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-36913

Qt 4.8.6 installer - check for valid mingw version broken

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Done
    • Affects Version/s: 4.8.6
    • Fix Version/s: 4.8.6
    • Component/s: Packaging & Installer
    • Labels:
      None

      Description

      See attached picture. The check is incorrect - In the mingw-builds package win32api.h is under i686-w64-mingw32\include .

      Anyhow, I suggest to remove the check altogether (which doesn't make any sense).

      To validate the installation, one could instead check for a i686-w64-mingw32 subfolder. Even better would be if it would actually run $INSTALLDIR\bin\g++.exe --version:

      g++ (i686-posix-dwarf, Built by MinGW-W64 project) 4.8.2
      Copyright (C) 2013 Free Software Foundation, Inc.
      This is free software; see the source for copying conditions.  There is NO
      warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
      

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            aksalova Akseli Salovaara
            Reporter:
            kkohne Kai Köhne
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes