Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-39240

[iOS] Setting the volume for individual QML Audio Elements does not work.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Done
    • Affects Version/s: 5.3.0
    • Fix Version/s: 5.5.0
    • Component/s: Multimedia
    • Labels:
      None
    • Environment:
      Qt 5.3.0 for iOS on an iPhone 5s and on an iPad 4 with iOS 7.1.1
    • Platform/s:
      iOS/tvOS/watchOS
    • Commits:
      4e07ff99f6ed49da3853c3f34cce393820105f1c

      Description

      Setting the volume for individual QML Audio Elements does not work.

      Even if I set the volume to 0.0, when I start to play, the audio file can still be heard. There is no difference between a volume of 0.0 and a volume 1.0. Regardless of the volume I set, the sound is played at the same intensity.

      This also happens for MediaPlayer QML element. The same behaviour might happen to other audio playing QML elements as well.

      I am getting this behaviour on an iPhone 5s and on an iPad 4 with iOS 7.1.1. This is working ok on MacOS, Windows or Android.

      This is similar or related to:

      https://bugreports.qt-project.org/browse/QTBUG-39036
      https://bugreports.qt-project.org/browse/QTBUG-37915
      https://bugreports.qt-project.org/browse/QTBUG-36756

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            • Assignee:
              ylopes Yoann Lopes
              Reporter:
              adrian.gabureanu Adrian Gabureanu
            • Votes:
              3 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Gerrit Reviews

                There are no open Gerrit changes