Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-42136

Issues with licensing information in configure script

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P5: Not important
    • Resolution: Done
    • Affects Version/s: 5.4.0 Beta
    • Fix Version/s: 5.6.3
    • Labels:
      None
    • Environment:
      Qt Open Source Edition
    • Commits:
      4e1d65071b0984fc9570b7328be3142b11b740d2

      Description

      The licensing information in the top level Qt configure script has some errors.

      "versions 2.1" is not grammatically correct, it should be "version 2.1".
      "versions 3" is not grammatically correct, it should be "version 2".

      It refers to both "GNU Lesser General Public License" and "Lesser GNU General Public License". I believe it should consistently be "GNU Lesser General Public License (LGPL)".

      Should it also mention that the software can be used under the GNU General Public License (GPL)?

      The software is offered under the GPL version 3, but the source code includes the GPL license version 2 in the file LICENSE.GPLv2.

        Attachments

        For Gerrit Dashboard: QTBUG-42136
        # Subject Branch Project Status CR V

          Activity

            People

            Assignee:
            buddenha Oswald Buddenhagen
            Reporter:
            tranter Jeff Tranter
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes