Qt
  1. Qt
  2. QTBUG-43110

Qt 5.4.0 RC, Framebuffer problems - output black on Virtual Machine

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: P2: Important P2: Important
    • Resolution: Done
    • Affects Version/s: 5.4.0 RC, 5.6.0
    • Fix Version/s: 5.6.1
    • Component/s: WebEngine
    • Environment:

      Oracle VM VirtualBox 4.3.20, Windows7 32bit, VS2013e update4, qt-opensource-windows-x86-msvc2013-5.4.0-rc.exe

      Description

      QtWebEngine in VirtualBox, Win7, 5.4.0-rc has problems in browser demo from examples. The browser demo doesn’t run OK, HTML pages are full black and browser crash later.

      Qt Creator, Application output make some error logs:

      OpenGL warning: DrvShareLists: unsupported
      QOpenGLFramebufferObject: Unsupported framebuffer format.

      5.4.0-beta works OK on same VM!

      No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

        Frederik Gladhorn added a comment -

        Do you have 3D acceleration for the guest VM enabled? Are you using the opengl build of Qt in both instances?

        Mario Krnjajic added a comment -

        Yes 3D acceleration is enabled.
        ANGLE build is used for both instances. RC: qt-opensource-windows-x86-msvc2013-5.4.0-rc.exe, Beta: qt-opensource-windows-x86-msvc2013-5.4.0-beta.exe ...

        Jonathan Courtois added a comment - - edited

        I have the same issue, 3D acceleration is enabled on VM, I use only openGL Desktop build: qt-opensource-windows-x86-msvc2013_opengl-5.4.0-rc

        Nando Lambrusco added a comment -

        I have tried it with Windows7 in VirtualBox with my application compiled with msvc1013 with OpenGL and without OpenGL. Both time the same black webengine-widgets.

        Günter Woigk added a comment - - edited

        still true on 5.5.
        QT Creator is unusable in VBox in full screen mode.
        I get the start screen contents surrounded with black border. i click on a project link and that it was. i cannot even leave fullscreen mode now.
        after ctrl-alt-del i see the (working) surrounding desktop and the contents is black. when i leave fullscreen mode in this state i can use QT Creator. dragging the Qt Creator window with the welcome screen shown looks like the welcome screen is some kind of video overlay. Whenever i enter the welcome screen in fullscreen mode again, same problem.
        VBox 4.3.28, AMD64, Windows7, onboard graphics, 3D accel yes, 1 core (2 cores crash during Qt installation, but that's likely Oracle to blame) Linux Mint 17
        you should consider to add a virtual box to the Qt test gear.

        Andrea Denzler added a comment - - edited

        same problem on 5.5
        Host: Ubuntu 14.04 + VWmare Workstation 10.0 + 3D Acceleration enabled + Hardware Compatibilty VMWare 9 + NVidia GTX 460 + NVidia binary driver 346.82 (proprietary, tested).
        Client: Ubuntu 14.04 + Qt5.5 downloaded and installed (not rebuilded).

        The issue is with fancybrowser example using WebEngine (WebKit works well). First page loads well. But if I paste+go an URL I get the framebuffer problem in 99% of the cases (black screen) and crash sometimes.
        Problem is both in fullscreen and not fullscreen.
        Unusable.

        Alexandru Croitor added a comment -

        Here is the summary of the situation.
        Latest Virtual Box version available (Version 5.0.26 r108824) + latest guest additions installed.
        Qt 5.6.1.

        On Virtual Box, Guest Windows 7 x64, MSVC2015, -opengl dynamic, with 3D acceleration enabled:

        QWebEngine app + Desktop OpenGL (QT_OPENGL environment variable set to desktop) does not work, because of issues with the Virtual box OpenGL driver, not much we can do there.

        QWebEngine app + ANGLE (QT_OPENGL to angle) seems to work fine.

        QWebEngine app + Software rendering (QT_OPENGL to software) seems to work fine as well.

        On Virtual Box, Guest Ubuntu 15.10 x64, with 3D acceleration enabled:

        QWebEngine apps won't work, because of issues with the Virtual box OpenGL driver, not much we can do.

        If 3D acceleration is disabled in VirtualBox, both on windows and linux the apps work fine, but are obviously slower.

        No tests were done on VMWare, because there's no license available at the moment.

        Previously before 5.6.x, on Windows + ANGLE there were issues because the Chromium part of the WebEngine used GPU acceleration as well as the Qt part, which led to multi-threading issues. Now the equivalent of --disable-gpu is sent to Chromium, using GPU acceleration only on the Qt side, thus ANGLE in VMs should work.


          People

          • Assignee:
            Alexandru Croitor
            Reporter:
            Mario Krnjajic
          • Votes:
            2 Vote for this issue
            Watchers:
            15 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Gerrit Reviews

              There are no open Gerrit changes