Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-43628

Weird behaviour / "unknown error" when entering wrong password with CUPS

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Done
    • Affects Version/s: 5.4.0
    • Fix Version/s: 5.5.0
    • Component/s: Network: HTTP, WebKit
    • Labels:
      None
    • Environment:
      Archlinux, CUPS 2.0.1
    • Commits:
      a4a5e663d6409fc19296c7329bdb0456fa7f54ec

      Description

      When using the CUPS webinterface (http://localhost:631/) via QtWebKit and entering a wrong password (e.g. via Administration -> Add printer), weird things happen:

      • With Firefox, I get another dialog asking me to authenticate, as expected.
      • With the example browser, cups uses 100% CPU and nothing happens - this might be a CUPS bug, but I can't trigger it with any other browser
      • With the Otter browser, I get an error page saying "Unknown error".

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            • Assignee:
              allan.jensen Allan Sandfeld Jensen
              Reporter:
              the compiler Florian Bruhin
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Gerrit Reviews

                There are no open Gerrit changes