Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-44820

QtwebEngine is not working on Embedded Linux with EGLFS plugin

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Not Evaluated
    • Resolution: Invalid
    • Affects Version/s: 5.5.0 Alpha
    • Fix Version/s: None
    • Component/s: WebEngine
    • Labels:
      None
    • Environment:
      Broadcom BCM 97429 (MIPS32R1 little endian)
      Linux 32 bits Kernel 3.3.8-3.0
      gcc 4.8.3
      uClibc 0.9.33.2
      Qt 5.5 Alpha from Git repo
      Using EGLFS plugin without X11/Wayland

      Description

      I'm building Qt from Git (5.5 branch) after this commit. The reason why I'm using the repo instead an official Qt release is because I need a change that is not included in Qt 5.4, neither in Qt 5.4.1 (Fix the build on eLinux)

      I modified the Qt source code to:

      • Implement a EGLFS plugin to work with Broadcom chip.
      • Add fixes to avoid compiling errors with uClibc in QtWebengine.

      I have testing QWebEngine with the example: qtwebengine/examples/weben
      gine/quicknanobrowser

      The user interface is shown on the screen when the application is launched and start to load the web site (http://www.qt.io), but the following trace appears and the application is aborted:

      [0126/190037:FATAL:gl_fence_egl.cc(42)] Check failed: value == EGL_SIGNALED_KHR || value == EGL_UNSIGNALED_KHR.
      

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            • Assignee:
              mibrunin Michael Bruning
              Reporter:
              jero3000 Jerónimo Muñoz Espinosa
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Gerrit Reviews

                There are no open Gerrit changes