Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-44968

QOpenGLShaderProgram Nvidia new GLSL compiler

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P3: Somewhat important
    • Resolution: Done
    • Affects Version/s: 5.3.0, 5.3.1, 5.3.2, 5.4.0
    • Fix Version/s: 5.5.0
    • Component/s: GUI: OpenGL
    • Labels:
      None
    • Commits:
      92ce89c1efdb7ddb589528901087e4ff50e55fe2

      Description

      Hi,

      Cause Nvidia drivers 347+ have new GLSL compiler there is one big problem.. that's QOpenGLShaderProgram add on start of whole code this horrible code:
      "#define lowp
      #define mediump
      #define highp"

      https://qt.gitorious.org/qt/qtbase/source/b17814e6ffcd048da7562d62ecad1bc38db7d980:src/gui/opengl/qopenglshaderprogram.cpp#L365

      Error: QOpenGLShader::compile(Vertex): 0(19) : error C0204: version directive must be first statement and may not be repeated

      Paradox is that #version is actually first line, so its caused by this.
      And its only caused by drivers new GLSL compiler.. when I downgrade to 344 its works, cause there is still old compiler.

      Thanks.

      Regards, glararan.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            lagocs Laszlo Agocs
            Reporter:
            glararan Lukáš Veteška
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes