Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-46009

Bundled Qt 5.4.0 platforminputcontext plugins makes apps crash on Qt 5.4.1

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P4: Low
    • Resolution: Done
    • Affects Version/s: 5.4.1
    • Fix Version/s: 5.5.0
    • Labels:
      None
    • Environment:
      Linux
    • Commits:
      c2e0c126d8be8782201b2e4b5e47d9abe7a64df0 (qtbase/5.5, 14.5.2015, 5.5)

      Description

      When I try to run a Qt application which bundles "plugins/platforminputcontexts/libcomposeplatforminputcontextplugin.so" from Qt 5.4.0 on a Linux where Qt 5.4.1 is installed, it crashes on startup. Stacktrace (without symbols) is here http://pastebin.com/vuGanpfT and it points to QPlatformInputContext::staticMetaObject().

      Assuming that the bugfix (https://codereview.qt-project.org/#/c/100511/) introduced in QTBUG-40691 has made it into Qt 5.4.1, is it possible that applications bundling plugins from Qt 5.4.0 (or maybe older) can crash on systems with Qt 5.4.1? Is this crash normal or did the bugfix change introduce binary incompatibility?

        Attachments

          Issue Links

          For Gerrit Dashboard: QTBUG-46009
          # Subject Branch Project Status CR V

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              gokceneraslan Goekcen
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: