Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-46839

Build fails in Qt3d module because of missing openglextensions

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Not Evaluated
    • Resolution: Duplicate
    • Affects Version/s: 5.5.0 RC
    • Fix Version/s: None
    • Component/s: Build System, Qt3D
    • Labels:
      None
    • Environment:
      Cross-compiling from Debain stable (32 bit) to i686-unknown-linux-gnu.

      Description

      Qt was configured for a cross-build to a system without Mesa or anything like that. When I build the build fails with:

      make[3]: Leaving directory `/tmp/e2/build/build/qt3d/src/core'
      cd render/ && ( test -e Makefile || /tmp/e2/build/build/qtbase/bin/qmake /tmp/e2/build/qt-everywhere-opensource-src-5.5.0-rc/qt3d/src/render/render.pro -o Makefile ) && make -f Makefile
      Project ERROR: Unknown module(s) in QT: openglextensions
      make[2]: *** [sub-render-make_first] Error 3
      make[2]: Leaving directory `/tmp/e2/build/build/qt3d/src'
      make[1]: *** [sub-src-make_first] Error 2
      make[1]: Leaving directory `/tmp/e2/build/build/qt3d'
      make: *** [module-qt3d-make_first] Error 2

        Attachments

        1. config.status
          1 kB
        2. config.summary
          4 kB
        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            • Assignee:
              buddenha Oswald Buddenhagen
              Reporter:
              rebemlix Rolf Eike Beer
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Gerrit Reviews

                There are no open Gerrit changes