Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-47839

QSysInfo::prettyProductName() returns wrong information on Windows 10

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Done
    • Affects Version/s: 5.4.2, 5.5.0
    • Fix Version/s: 5.5.1
    • Component/s: Core: Other
    • Labels:
      None
    • Environment:
      Windows 10
    • Commits:
      8046a574d27b71ac9540b6cd3c029c2a83dd731e

      Description

      The following code produces unexpected output when running on Windows 10:

      #include <QDebug>
      #include <QSysInfo>

      int main(int argc, char *argv[])
      {
      Q_UNUSED(argc);
      Q_UNUSED(argv);

      // EXPECTED: "Windows 10"
      // ACTUAL: "Windows "
      qDebug() << QSysInfo::prettyProductName();

      return 0;
      }

      After looking through the Qt sources this appears to be due to the winVer_helper() method in qglobal.cpp not handling the QSysInfo::WV_WINDOWS10 enum value.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            mkrems Marcel Krems
            Reporter:
            Jivaro_Thomas Jivaro Thomas
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes