Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-48988

New-style QObject::connect fails with QPointer<T> (regression)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Not Evaluated
    • Resolution: Cannot Reproduce
    • Affects Version/s: 5.6
    • Fix Version/s: None
    • Component/s: Core: Object Model
    • Labels:
      None

      Description

      Attached test case is reduced from KDE projects "skrooge" and "kbibtex" which fail to build with today's 5.6 branch of qtbase, but apparently build on an older branch (5.4?).

      The documentation for QPointer::operator T * () const says: "Because of this function you can pass a QPointer<T> to a function where a T * is required."

      This does not work for the new-style connect in the test case. Changing "test" to "test.data()" is a workaround, but since this seems to be a regression, I am not sure if it is a bug that needs to be fixed in Qt.

        Attachments

        1. err.txt
          7 kB
        2. main.cpp
          0.4 kB
        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            • Assignee:
              thiago Thiago Macieira
              Reporter:
              cfeck Christoph Feck
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Gerrit Reviews

                There are no open Gerrit changes