Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-50754

WebEngine becomes black when calling winId() on another widget

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Not Evaluated
    • Resolution: Duplicate
    • Affects Version/s: 5.7.0
    • Fix Version/s: 5.6.0 RC
    • Component/s: WebEngine
    • Labels:
      None
    • Environment:
      KUbuntu 14.04 32-bit, Qt 5.5.1, QtWebEngine from dev

      Description

      Using Qt 5.5.1, WebEngine from today's Git and 47-based Chromium. When I call winId() on some widget, WebEngine becomes black. Quick and dirty sample project is attached. Steps to reproduce:

      1) compile and run:

      $ qmake && make
      $ ./webeng3 file://$PWD/w.html

      2) Enter some URL in the appeared window

      Result:

      The application will load the specified URL into the WebEngine widget, then call winId() on the plugin. After calling winId(), WebEngine becomes completely black.

        Attachments

        1. snapshot1.png
          snapshot1.png
          18 kB
        2. webeng3.tar.gz
          1 kB

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              allan.jensen Allan Sandfeld Jensen
              Reporter:
              dmitry64 Dmitry
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes