Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-50838

OpenGL / OpenGL ES 2 / QMAKE_LIBS_EGL

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Done
    • Affects Version/s: 5.5.1, 5.6.0
    • Fix Version/s: 5.8.0 Alpha
    • Component/s: QPA: EGLFS
    • Environment:
      Yocto
      branch: jethro and krogoth
      layer: meta-qt5
      branch: master
      layer: meta-raspberrypi
      option: gles2
    • Commits:
      4940194a35a5776aaaf7959441af58c0a4c04247

      Description

      In order to have the recipe qtbase compiling it is necessary to add -lGLESv2 to the QMAKE_LIBS_EGL variable.
      Right now... when I add the option gles2 we get only the -lEGL. I was more expecting something like -lGLESv2.

      If we have a look to the mkspecs of the pi2, we can see:
      QMAKE_LIBS_EGL = "-lEGL -lGLESv2"

      It seems weird to add the library GLESv2 when we select the exact name option.

      The problem might be somewhere in meta-qt5, meta-raspberrypi or qtbase.

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              lagocs Laszlo Agocs
              Reporter:
              jgueytat JulienGueytat
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes