Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-51517

Runtime warning about COMPAT signal QProcess::error

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Done
    • Affects Version/s: 5.6.0
    • Fix Version/s: 5.6.1
    • Component/s: Core: I/O
    • Labels:
      None

      Description

      QProcess::error was deprecated in 5.6 in favor of a new QProcess::errorOccurred, and marked with QT_MOC_COMPAT .

      This has the effect that now every use of QProcess::error in a QObject::connect leads to a runtime warning that cannot be disabled

      QObject::connect: Connecting from COMPAT signal (QProcess::error(QProcess::ProcessError))
      

      This seems to draconic for apps that need to support a wider range of Qt versions.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            kkohne Kai Köhne
            Reporter:
            kkohne Kai Köhne
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes