Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-51843

QtWebEngine Compilation Issue // Windows 7 x64 // VC2015 with /D_USING_V110_SDK71_

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Not Evaluated
    • Resolution: Duplicate
    • Affects Version/s: 5.6.0 RC
    • Fix Version/s: None
    • Component/s: WebEngine
    • Labels:
      None
    • Environment:
      Windows 7 x64 with Visual Studio 2015 using Compiler Flag "/D_USING_V110_SDK71_" and configure flag -target xp

      Description

      I receive the following compilation issue with using the following configure call: configure -opensource -confirm-license -target xp -nomake tests -nomake examples -prefix C:\Build\qt-5.6.0-rc\qt-install

      Compiler Output:
      Microsoft (R) Program Maintenance Utility Version 14.00.23506.0
      Copyright (C) Microsoft Corporation. All rights reserved.

      ( if not exist Makefile.gyp_run C:\Build\qt-5.6.0-rc\qt-build\qtbase\bin\qmake C:\Build\qt-5.6.0-rc\qt-everywhere-opensource-src-5.6.0-rc\qtwebengine\src\core\gyp_run.pro -o Makefile.gyp_run )
      && nmake -f Makefile.gyp_run
      'git' is not recognized as an internal or external command,
      operable program or batch file.
      Project MESSAGE: Running gyp_qtwebengine "C:/Build/qt-5.6.0-rc/qt-build/qtwebengine/src/core" D qt_cross_compile=0 -D qt_os="win32" -I config/windows.gypi -D qtwe_chromium_obj_dir="C:/Build/qt-5.6.0
      rc/qt-build/qtwebengine/src/core/Debug/obj/src/3rdparty/chromium" -D perl_exe="perl.exe" -D bison_exe="bison.exe" -D gperf_exe="gperf.exe" --no-parallel -D qt_egl_library="libEGLd.lib" -D qt_glesv2_li
      brary="libGLESv2d.lib" -D qt_gl="angle" -G msvs_version=2015 -D use_qt=1 -D v8_use_external_startup_data=0 -D enable_basic_printing=0 -D enable_print_preview=0 -D enable_web_speech=0 -D disable_nacl=1
      -D remoting=0 -D use_ash=0 -D fastbuild=2 -D disable_glibcxx_debug=1 -D remove_webcore_debug_symbols=1 -D remove_v8base_debug_symbols=1 -D disable_fatal_linker_warnings=1 -D target_arch=ia32...
      using python: C:\Python27\python.exe version: 2.7.10
      'git' is not recognized as an internal or external command,
      operable program or batch file.
      Using extra options found in c:\build\qt-5.6.0-rc\qt-everywhere-opensource-src-5.6.0-rc\qtwebengine\src\core\qtwebengine_extras.gypi
      Updating projects from gyp files...
      Traceback (most recent call last):
      File "C:/Build/qt-5.6.0-rc/qt-everywhere-opensource-src-5.6.0-rc/qtwebengine/tools/buildscripts/gyp_qtwebengine", line 178, in <module>
      sys.exit(gyp.main(args))
      File "c:\build\qt-5.6.0-rc\qt-everywhere-opensource-src-5.6.0-rc\qtwebengine\src\3rdparty\chromium\tools\gyp\pylib\gyp_init_.py", line 538, in main
      return gyp_main(args)
      File "c:\build\qt-5.6.0-rc\qt-everywhere-opensource-src-5.6.0-rc\qtwebengine\src\3rdparty\chromium\tools\gyp\pylib\gyp_init_.py", line 514, in gyp_main
      options.duplicate_basename_check)
      File "c:\build\qt-5.6.0-rc\qt-everywhere-opensource-src-5.6.0-rc\qtwebengine\src\3rdparty\chromium\tools\gyp\pylib\gyp_init_.py", line 98, in Load
      generator.CalculateVariables(default_variables, params)
      File "c:\build\qt-5.6.0-rc\qt-everywhere-opensource-src-5.6.0-rc\qtwebengine\src\3rdparty\chromium\tools\gyp\pylib\gyp\generator\ninja.py", line 1682, in CalculateVariables
      gyp.msvs_emulation.CalculateCommonVariables(default_variables, params)
      File "c:\build\qt-5.6.0-rc\qt-everywhere-opensource-src-5.6.0-rc\qtwebengine\src\3rdparty\chromium\tools\gyp\pylib\gyp\msvs_emulation.py", line 1071, in CalculateCommonVariables
      msvs_version = gyp.msvs_emulation.GetVSVersion(generator_flags)
      File "c:\build\qt-5.6.0-rc\qt-everywhere-opensource-src-5.6.0-rc\qtwebengine\src\3rdparty\chromium\tools\gyp\pylib\gyp\msvs_emulation.py", line 924, in GetVSVersion
      allow_fallback=False)
      File "c:\build\qt-5.6.0-rc\qt-everywhere-opensource-src-5.6.0-rc\qtwebengine\src\3rdparty\chromium\tools\gyp\pylib\gyp\MSVSVersion.py", line 437, in SelectVisualStudioVersion
      raise ValueError('Could not locate Visual Studio installation.')
      ValueError: Could not locate Visual Studio installation.
      Project ERROR: – running gyp_qtwebengine failed –
      NMAKE : fatal error U1077: '(' : return code '0x3'
      Stop.
      NMAKE : fatal error U1077: 'cd' : return code '0x2'
      Stop.
      NMAKE : fatal error U1077: 'cd' : return code '0x2'
      Stop.
      NMAKE : fatal error U1077: 'cd' : return code '0x2'
      Stop.

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              kkohne Kai Köhne
              Reporter:
              walteste Stefan Walter
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes