Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-52951

libdl config test fails on all BSD operating systems

    XMLWordPrintable

    Details

    • Commits:
      e9628fbd391972d4ffe5882d283d512df7fa705c

      Description

      qtbase/config.tests/unix/libdl/libdl.pro contains

      !qnx: LIBS+= -ldl

      which doesn't work on any BSD operating system (Net, Open, FreeBSD) as the dl calls are part of libc and not a separate library. The test fails and the result is a build that can't load any plugins, especially platform plugins due to declaring the QT_NO_DYNAMIC_LIBRARY during compile.

      The libdl.pro file should exclude freebsd, netbsd, openbsd besides qnx. The issue is urgent as we found the reasons for the failing of calling programs without failure just today and were trying to nail the cause since two weeks already. Other BSD porters will likely be hit by the same problem when trying to port 5.7 to their OS.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            • Assignee:
              gonzo Oleksandr Tymoshenko
              Reporter:
              rnolden Marie Loise Nolden (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Gerrit Reviews

                There are no open Gerrit changes