Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-54172

WebEngineView fails to scroll to anchor when making it visible directly before calling setUrl

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Done
    • Affects Version/s: 5.6.1, 5.7.0
    • Fix Version/s: 5.10
    • Component/s: WebEngine
    • Labels:
      None
    • Environment:
      Qt 5.6.0 on Linux, high DPI display (2560x1440 13").
    • Commits:
      15b6ab6a20ff7305f2b3558f8450e388148a0312

      Description

      When invoking Qt Creator's help viewer (based on QtWebEngine) at the right side (e. g. by pressing F1) for a new page (for a new class) it fails to scroll to the correct item.

      If the help viewer already has the correct page open (i. e. pressing F1 on another member of the same class) it scrolls to the correct item.

      It doesn't seem to matter whether the help view has been hidden.

        Attachments

          Issue Links

          For Gerrit Dashboard: QTBUG-54172
          # Subject Branch Project Status CR V

            Activity

              People

              Assignee:
              pvarga Peter Varga
              Reporter:
              sandsmark Martin Sandsmark
              Votes:
              4 Vote for this issue
              Watchers:
              11 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes