Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-54486

Document QtWebEngine support for OS X 10.9

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Done
    • Affects Version/s: 5.7.0
    • Fix Version/s: 5.7.1
    • Component/s: WebEngine
    • Labels:
      None
    • Platform/s:
      macOS
    • Commits:
      9e65aaf4e0d0c5b5d927f2fbc5c8aa052bae24b8

      Description

      According to this change QtWebEngine (since Qt 5.7) needs SDK 10.10.3 on OS X 10.9 - however:

      • This is not mentioned in the change file
      • The documentation doesn't mention this (quite the contrary - it says it'd work with Xcode 5.1 with OS X 10.9)
      • The current requirement (SDK 10.10.3 on OS X 10.9) seems to be unsupported by Apple?

      IRC logs:

      09:33 <alcroito> The-Compiler: Afaik webengine 5.7 is not going to be officially supported  for 10.9 anymore
      09:36 <alcroito> The-Compiler: Also without the build log, it's kind of a guessing game what went wrong
      09:37 <alcroito> The-Compiler: My initial guess would be that if the build is done with the 10.10 sdk shipped with xcode 6.2, then it will not be enough, because it requires a newer 10.10 sdk
      09:38 <The-Compiler> alcroito: yeah, I just mentioned that guess as well - seems like 10.10.3 is required?
      09:38 <alcroito> The-Compiler: Yes, which ships minimum with xcode 6.3, which is not supported on 10.9, which is why we will probably not support it either
      09:39 <The-Compiler> alcroito: FWIW http://doc.qt.io/qt-5/qtwebengine-platform-notes.html#os-x says "On OS X, Xcode version 5.1 or later on OS X 10.9 or later is required." for 5.7 which implies that'd work
      09:39 <alcroito> The-Compiler: That is outdated, and we will have to update it. We discovered that 10.9 won't work fairly recently
      09:40 <alcroito> The initial assumption was that 10.10.3 sdk would be shipped with xcode 6.2, but that's not the case.
      09:41 <The-Compiler> So homebrew would have to drop QtWebEngine for 10.9 with Qt 5.7?
      09:41 <alcroito> You can of course take the 10.10.3 from a newer xcode, and build with the older one, but that might not work forever
      

      This was a surprise for the Homebrew project.

      The documentation should be updated to point this out, or alternatively to point out 10.9 is entirely unsupported.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            • Assignee:
              alexandru.croitor Alexandru Croitor
              Reporter:
              the compiler Florian Bruhin
            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Gerrit Reviews

                There are no open Gerrit changes