Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-55193

Charts module does not build with Qt 5.8 -no-opengl

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Done
    • Affects Version/s: 5.8.0 Alpha
    • Fix Version/s: 5.8.0 Alpha
    • Component/s: Charts
    • Labels:
      None

      Description

      As of Qt 5.8 it is no longer true that qtHaveModule(quick) == OpenGL support available. It is now possible to build the QtQuick module without OpenGL support, and so modules that require OpenGL need to be clear that they need QtQuick and OpenGL now.

      It may be desirable that QtCharts also work with QtQuick backends other than OpenGL (like the Software ore D3D12), in which case usage of SceneGraph nodes that require OpenGL should be limited to backends that support OpenGL.

        Attachments

        For Gerrit Dashboard: QTBUG-55193
        # Subject Branch Project Status CR V

          Activity

            People

            Assignee:
            e0348803 Miikka Heikkinen
            Reporter:
            janichol Andy Nichols
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes