Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-56975

QtQuick/QML displayed with wrong colors on Big Endian architecture

    XMLWordPrintable

Details

    • Bug
    • Status: Reported
    • P4: Low
    • Resolution: Unresolved
    • 5.7.0
    • None
    • None
    • OS: AOSC OS (https://aosc.io/)
      Qt version: 5.7.0
      Architecture: PPC64
      Mesa version: 13.0.0/12.0.3 (both shows the same issue)
    • Linux/X11

    Description

      I was trying to build and run Plasma 5.8 on my PowerMac G5 today (the graphics card is not relevant...), and I found that the desktop was shown in wrong color - a strong blue and violet hue, as described in my original KDE bug report here: https://bugs.kde.org/show_bug.cgi?id=372202.

      Anyways, I have attached two screenshots of the same animation.qml from the QtDeclarative examples, run using the same version of Qt with qmlscene, on PPC64 and AMD64.

      ----------

      Leslie Zhai has provided his screenshot of running the same demo on AMD64: https://dn-fishroom.qbox.me/img/7b4e.jpeg.

      My screenshot is attached below.

      Attachments

        Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

              srutledg Shawn Rutledge
              mingcongbai Mingcong Bai
              Votes:
              2 Vote for this issue
              Watchers:
              12 Start watching this issue

              Dates

                Created:
                Updated:

                Gerrit Reviews

                  There are no open Gerrit changes