Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-57265

[REG 5.6.1->5.6.2] macdeploy -always-overwrite fails on qml/quick plugins

    Details

    • Commits:
      d07e6b891e69c9ce4bed9e91c917d81d0d8a6ae1

      Description

      With latest update to 5.6.2 (from 5.6.1) and 5.7.1 (from 5.7.0) macdeploy command fails on several qml/quick plugins.

      Command:
      macdeploy "build/packages/App/data" -no-strip -qmldir=res/qml/ -always-overwrite -executable="build/packages/App/data/Contents/MacOS/Application"

      Log:
      ERROR: "/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/strip: string table not at the end of the file (can't be processed) in file: /Users/user/project/installer/mac/build/packages/App/data/Contents/PlugIns/quick/libqtquick2plugin.dylib\n"
      ERROR: ""
      ERROR: Could not parse otool output: "/Users/user/project/installer/mac/build/packages/App/data/Contents/PlugIns/quick/libqtquick2plugin.dylib:\n"
      ERROR: "/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/strip: string table not at the end of the file (can't be processed) in file: /Users/user/project/installer/mac/build/packages/App/data/Contents/PlugIns/quick/libqquicklayoutsplugin.dylib\n"
      ERROR: ""
      ERROR: Could not parse otool output: "/Users/user/project/installer/mac/build/packages/App/data/Contents/PlugIns/quick/libqquicklayoutsplugin.dylib:\n"
      ... - full log attached

      With -no-strip option I get only messages that otool output cannot be parsed:
      ERROR: Could not parse otool output: "/Users/user/project/installer/mac/build/packages/App/data/Contents/PlugIns/quick/libqquicklayoutsplugin.dylib:\n"

      In both cases plugin files copied to app bundle are corrupted - much smaller than original ones. Of course app package is not working.

      It is working correctly on 5.6.1 and 5.7.0. When I copied Qt/5.6/clang_64/qml from version 5.6.1 to version 5.6.2 it was working correctly. Something is wrong with files distributed in Qt/5.6/clang_64/qml in version 5.6.2 an 5.7.1.

      I also used macdeploy from 5.6.1 in 5.6.2 and it failed too - it is not a problem with macdeploy tool itself, but with qml/quick plugins.

      For now I can revert to 5.6.1 but it looks as quite import issue.

        Attachments

        1. log.txt
          6 kB
        2. output.zip
          1.96 MB
        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            • Assignee:
              andysh Andy Shaw
              Reporter:
              kmaterka Konrad Materka
            • Votes:
              12 Vote for this issue
              Watchers:
              22 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Gerrit Reviews

                There are no open Gerrit changes