Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-57419

Plugin.required is read-only property

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Done
    • Affects Version/s: 5.7.0
    • Fix Version/s: 5.9.2
    • Labels:
      None
    • Environment:
      Ubuntu 14.04, Qt 5.7.0

      Description

      The Example Usage section for Plugin includes the code:

      Plugin {
          id: plugin
          preferred: ["here", "osm"]
          required: Plugin.AnyMappingFeatures | Plugin.AnyGeocodingFeatures
      }
      

      However, using this QML...

      Map {
          plugin: Plugin {
              preferred: ["here", "osm"]
              required: Plugin.AnyMappingFeatures
          }
      }
      

      ...produces the error:

      qrc:/navigation/Navigation.qml:124 Invalid property assignment: "required" is a read-only property

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            paangele Paolo Angelelli
            Reporter:
            phrogz Gavin Kistner
            Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes