Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-58299

Compositing using the wayland-egl integration doesn't work with NVIDIA driver version 370

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Done
    • Affects Version/s: 5.8.0 RC
    • Fix Version/s: None
    • Component/s: QPA: Wayland
    • Labels:
      None
    • Environment:

      Description

      It seems NVIDIA has changed it's wayland drivers to use some new EGL extensions to communicate eglstreams.

      The current version of qtwayland, doesn't work with the latest NVIDIA drivers (375). The test was to run the qwindow-compositor and a qmlscene connecting to the compositor. The same behavior can be seen when trying to connect any other egl based client

        Attachments

        For Gerrit Dashboard: QTBUG-58299
        # Subject Branch Project Status CR V

          Activity

            People

            Assignee:
            johanhelsing Johan Helsing
            Reporter:
            gagi Dominik Holland
            Votes:
            0 Vote for this issue
            Watchers:
            8 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes