Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-58547

QtWebengine fails to build when a previous version is already installed

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P3: Somewhat important
    • Resolution: Duplicate
    • Affects Version/s: 5.8.0
    • Fix Version/s: None
    • Component/s: WebEngine
    • Labels:
      None
    • Environment:
      Gentoo Linux

      Description

      I had 5.7.1 version installed and during upgrade to 5.8.0, the webengine module failed to compile due to already installed qtwebengine header files. Compilation was interrupted during compiling src/core/network_delegate_qt.cpp because of absent WebEngineUrlRequestInfo::ResourceTypeLast enum member from commit 95a22234a4671e6e79ce1cecbd720551a185d278.

      Steps to reproduce:
      1. Install Qt version 5.7.1 into /usr/lib/qt5
      2. Upgrade to 5.8.0 compiling and installing module-by-module until the webengine one.

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              buddenha Oswald Buddenhagen
              Reporter:
              eugeneshalygin Eugene Shalygin
              Votes:
              1 Vote for this issue
              Watchers:
              7 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes