Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-58596

Compiling Qt QOCI driver fails with message "Project ERROR: Library 'oci' is not defined."

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Duplicate
    • Affects Version/s: 5.7.1, 5.8.0
    • Fix Version/s: None
    • Component/s: SQL Support
    • Labels:
      None
    • Environment:
      Ubuntu 16.04 (Linux)
      i386
      Qt built from source

      Description

      When I try compiling following the instructions from the documentation, the compilation fails with the message "Project ERROR: Library 'oci' is not defined." We have used the same procedure for building the OCI driver for 5.7.0, and then it worked.

      See the attached build script and log file (qmake with -d parameter output) for more detailed information.

        Attachments

        1. build_oci.clean.log
          3.05 MB
        2. build_oci.clean.sh
          0.4 kB

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              • Assignee:
                buddenha Oswald Buddenhagen
                Reporter:
                ato Andreas
              • Votes:
                2 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes