Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-59318

QGraphicsView fails to properly set QOpenGLContex::defaultFramebufferObject

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Done
    • Affects Version/s: 5.7.1
    • Fix Version/s: 5.9.0 Beta 2
    • Labels:
      None
    • Environment:
      Debian, GCC 6.2.1, Qt 5.7.1

      Description

      I'm using QGraphicsView with QOpenGLWidget as viewport. When using QOpenGLFramebufferObject::release() within QGraphicsItem::paint() the current OpenGL framebuffer is set to the system's default and not to the QOpenGLWidget's framebuffer.

      QOpenGLWidgetPrivate::invokeUserPaint() sets a flag on QOpenGLContext before calling virtual QOpenGLWidget::paintGL(). QOpenGLContext::defaultFramebufferObject() then returns the QOpenGLWidget's framebuffer while in paintGL().

      This initialization step seems to be missing when using QOpenGLWidget as viewport for QGraphicsView.

        Attachments

        1. Main.cc
          1 kB
          Ole
        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            • Assignee:
              lagocs Laszlo Agocs
              Reporter:
              tfm123 Ole
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Gerrit Reviews

                There are no open Gerrit changes