Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-59801

QtWebEngine build error with system_icu and ICU 58

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P3: Somewhat important
    • Resolution: Done
    • Affects Version/s: 5.8.0
    • Fix Version/s: 5.9.0 Beta 2
    • Component/s: WebEngine
    • Labels:
      None
    • Environment:
      - Gentoo Linux
      - Installed ICU 58.1 or later(58.2 is latest at present)
      - qt overlay (https://github.com/gentoo/qt)

      Description

      [Issue]

      • Building QtWebEngine fails with error "Update aspirational_scripts per Unicode 9.0"

      [Reproduce procedure]

      • Install ICU 58 or late on Linux host
      • Build QtWebEngine with system_icu option

      [Expected behavior]

      • Build succeeds.

      [Root cause]
      It is due to ICU 58 has been out with the release of Unicode 9.0.
      Upstream chromium has already been fixed [1]

      On qtwebengine-chromium, older than 56-based branches are affected by this issue.

      [1] https://codereview.chromium.org/2436113003

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            • Assignee:
              kenya888 Takahiro Hashimoto
              Reporter:
              kenya888 Takahiro Hashimoto
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Gerrit Reviews

                There are no open Gerrit changes