Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-60334

The position of IME is wrong (HiDPI)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P3: Somewhat important
    • Resolution: Done
    • Affects Version/s: 5.9.0 Beta 2, 5.9.0 Beta 3, 5.9.0 RC, 5.9.0
    • Fix Version/s: 5.9.2, 5.10.0 Alpha
    • Component/s: WebEngine
    • Labels:
      None
    • Environment:
      Wndows10-1703 and default Chinese IME
    • Commits:
      5bc8671260bc716be9dffe61e84c214ca37ca5f6

      Description

      Steps to reproduce:
      1. use simplebrowser demo open https://docs.google.com/document/d/1D2YoMcbhp4z2uWG9sJAysgpMmXyQYzpdZ56l8KXvYZk/edit
      2. try typing some words into URL bar.
      3. then typing some words into google docs, the position of IME was wrong.

      I guess that because the position of the IME does not update when the cursor focus in webpage. The qt 5.7.1 work fine.

        Attachments

        1. 1.png
          1.png
          212 kB
        2. right.png
          right.png
          31 kB
        3. wrong.png
          wrong.png
          60 kB
        4. wrong1.png
          wrong1.png
          56 kB
        5. wrong2.png
          wrong2.png
          92 kB
        6. wrong3.png
          wrong3.png
          7 kB

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              kkohne Kai Köhne
              Reporter:
              vidarxu Carter Davies
              Votes:
              0 Vote for this issue
              Watchers:
              8 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes