Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-61731

qtbase-opensource-src-5.9.1 doesn't build with Linux accessibility support

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Done
    • Affects Version/s: 5.9.1
    • Fix Version/s: 5.9.2
    • Component/s: Build System
    • Labels:
      None
    • Environment:
      OpenMandriva Lx 3.02
    • Commits:
      386af91c57948b88ba98cb040430e4a3878e3e3b

      Description

      Building qtbase 5.9.1 on Linux always results in a build with accessibility support disabled.

      The problem is that the config option for accessibility-atspi-bridge checks for config.atspi, which isn't defined anywhere - it should check for libs.atspi (which is set if pkg-config finds atspi-2) instead.

      I've attached a patch that fixes the problem.

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              • Assignee:
                bero Bernhard Rosenkränzer
                Reporter:
                bero Bernhard Rosenkränzer
              • Votes:
                0 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes