Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-63325

qmake lessThan(QT_VERSION, ...) fails for Qt 5.10.0

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Not Evaluated
    • Resolution: Invalid
    • Affects Version/s: 5.10.0 Alpha
    • Fix Version/s: None
    • Component/s: Build tools: qmake
    • Labels:
      None
    • Environment:
      Qt 5.10.0 Alpha built from source on Ubuntu Linux 17.04.

      /usr/local/Qt-5.10.0/bin/qmake --version
      QMake version 3.1
      Using Qt version 5.10.0 in /usr/local/Qt-5.10.0/lib

      Description

      With a project file containing:

      lessThan(QT_VERSION, 5.9.0): error(This project requires Qt 5.9.0 or later)

       

      Running qmake for Qt 5.10.0 Alpha reports:

      Project ERROR: This project requires Qt 5.9.0 or later

      It should report Qt 5.10.0 as newer than 5.9.0.

       

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            buddenha Oswald Buddenhagen
            Reporter:
            tranter Jeff Tranter
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes