Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-64129

Add proper warnings when attempting to use legacy QtWebKit

    XMLWordPrintable

    Details

    • Type: Suggestion
    • Status: Reported
    • Priority: Not Evaluated
    • Resolution: Unresolved
    • Affects Version/s: 5.6.0, 5.9.0
    • Fix Version/s: None
    • Component/s: WebKit
    • Labels:
      None

      Description

      We need to clear up current situation of QtWebKit, properly mark deprecated versions (so called legacy, everything older than 5.212 branch) and let users know that there is important upgrade available.

      There should be configure (and maybe even runtime) warning when attempting to use older versions (at least added to branches of LTS releases) which should also mention 5.212 as drop-in replacement, for example some link to "generic" wiki article about upgrading from legacy, preferably without mentioning any version in URL (same could apply to deprecation warnings).

      This should help a bit with adoption of up to date version.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            annulen Konstantin Tokarev
            Reporter:
            emdek MichaƂ Dutkiewicz
            Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:

                Gerrit Reviews

                There are no open Gerrit changes