Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-64135

WebSockets module is incorrectly licensed, readme states LGPLv2.1, code doesn't.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Done
    • Affects Version/s: 5.9.2, 5.10.0 Beta 2, 5.10.0, 5.10.1, 5.11.0 Alpha
    • Fix Version/s: 5.11.0 RC 1
    • Component/s: WebSockets
    • Labels:
      None

      Description

      Readme states:

      ### License
      This code is licensed under LGPLv3 or LGPLv2.1.
      

      That could be seen on http://code.qt.io/cgit/qt/qtwebsockets.git/tree/README.md?h=5.9.0#n37 and https://github.com/qt/qtwebsockets#license , for example.

      Code lists only LGPLv3 and GPLv2/GPLv3+, does not list LGPLv2.1, and states:

      ** Copyright (C) 2016 Kurt Pattyn <pattyn.kurt@gmail.com>.
      ** Contact: https://www.qt.io/licensing/
      **
      ** This file is part of the QtWebSockets module of the Qt Toolkit.
      **
      ** $QT_BEGIN_LICENSE:LGPL$
      ** Commercial License Usage
      ** Licensees holding valid commercial Qt licenses may use this file in
      ** accordance with the commercial license agreement provided with the
      ** Software or, alternatively, in accordance with the terms contained in
      ** a written agreement between you and The Qt Company. For licensing terms
      ** and conditions see https://www.qt.io/terms-conditions. For further
      ** information use the contact form at https://www.qt.io/contact-us.
      **
      ** GNU Lesser General Public License Usage
      ** Alternatively, this file may be used under the terms of the GNU Lesser
      ** General Public License version 3 as published by the Free Software
      ** Foundation and appearing in the file LICENSE.LGPL3 included in the
      ** packaging of this file. Please review the following information to
      ** ensure the GNU Lesser General Public License version 3 requirements
      ** will be met: https://www.gnu.org/licenses/lgpl-3.0.html.
      **
      ** GNU General Public License Usage
      ** Alternatively, this file may be used under the terms of the GNU
      ** General Public License version 2.0 or (at your option) the GNU General
      ** Public license version 3 or any later version approved by the KDE Free
      ** Qt Foundation. The licenses are as published by the Free Software
      ** Foundation and appearing in the file LICENSE.GPL2 and LICENSE.GPL3
      ** included in the packaging of this file. Please review the following
      ** information to ensure the GNU General Public License requirements will
      ** be met: https://www.gnu.org/licenses/gpl-2.0.html and
      ** https://www.gnu.org/licenses/gpl-3.0.html.
      **
      ** $QT_END_LICENSE$
      

      Also, the LGPLv2.1 license text is not included in the repo as it should be per the Readme.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            kkohne Kai Köhne
            Reporter:
            chalker Сковорода Никита
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes