Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-64161

QPSQL does not support PostgreSQL 10

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Done
    • Affects Version/s: 5.9.2, 5.10.0 Alpha, 5.10.0 Beta 1, 5.10.0 Beta 2, 5.10.0 Beta 3
    • Fix Version/s: 5.9.3, 5.10.0
    • Component/s: SQL Support
    • Labels:
      None
    • Environment:
    • Commits:
      435c4b2ccbbb7284918dd2d4a14f8e44c3977d98

      Description

      • QT-5.9.[1,2] (and future QT-5.10?) in the upstram do not support PostgreSQL 10.
      • Users who use QPSQLDriver in there applications (e.g. who use akonadi-backend-postgresql) with PostgreSQL 10 are not able to work completely.

      Attached patch works for Qt 5.9.1 and Qt 5.9.2.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            mabrand Mark Brand
            Reporter:
            idamir Damir Islamov
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes