Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-65079

Webengine cross compilation broken since 5.10

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Done
    • Affects Version/s: 5.10.0
    • Fix Version/s: 5.10.1
    • Component/s: WebEngine
    • Labels:
      None
    • Environment:
      Linux, LibreELEC, crossbuild.
    • Commits:
      d502c6e9d09803dd268100f8c53cf7bc563e3d1d

      Description

      I'm am crossbuilding Qt with QtWebengine on LIBRELEC for arm64 on an intel host.

      5.9.2 was working fine but it seems that something broke with 5.10.

      it will build completely Qt and also half of webengine but seems to fail here 

       

      [9722/20378] LINK host/transport_security_state_generator
      FAILED: host/transport_security_state_generator 
      /home/longchair/github/longchair/LibreELEC.tv/build.PlexMediaPlayer-ROCK64.aarch64-9.0-devel/toolchain/bin/python2 "../../3rdparty/chromium/build/toolchain/gcc_link_wrapper.py" --output="host/transport_security_state_generator" -- /usr/bin/g++ -Wl,--fatal-warnings -fPIC -Wl,-z,noexecstack -Wl,-z,now -Wl,-z,relro -Wl,-z,defs -Wl,--no-as-needed -lpthread -Wl,--as-needed -fuse-ld=gold -B../../3rdparty/chromium/third_party/binutils/Linux_x64/Release/bin -m64 -Wl,-O1 -Wl,--gc-sections -Wl,-rpath-link=host -Wl,--disable-new-dtags -L/home/longchair/github/longchair/LibreELEC.tv/build.PlexMediaPlayer-ROCK64.aarch64-9.0-devel/toolchain/aarch64-libreelec-linux-gnueabi/sysroot/usr/lib -o "host/transport_security_state_generator" -Wl,--start-group @"host/transport_security_state_generator.rsp" -Wl,--end-group -ldl -lpthread -lrt -lnss3 -lnssutil3 -lsmime3 -lsoftokn3 -lplds4 -lplc4 -lnspr4 
      /usr/bin/ld.gold: warning: skipping incompatible /home/longchair/github/longchair/LibreELEC.tv/build.PlexMediaPlayer-ROCK64.aarch64-9.0-devel/toolchain/aarch64-libreelec-linux-gnueabi/sysroot/usr/lib/libpthread.so while searching for pthread
      /usr/bin/ld.gold: fatal error: /home/longchair/github/longchair/LibreELEC.tv/build.PlexMediaPlayer-ROCK64.aarch64-9.0-devel/toolchain/aarch64-libreelec-linux-gnueabi/sysroot/usr/lib/libdl.so: unsupported ELF machine number 183
      collect2: error: ld returned 1 exit status

      From my limited understanding, it seems it's trying to build something on host, but it is passing a library path to compiler that is a path for target libs :

       

      -L/home/longchair/github/longchair/LibreELEC.tv/build.PlexMediaPlayer-ROCK64.aarch64-9.0-devel/toolchain/aarch64-libreelec-linux-gnueabi/sysroot/usr/lib

      Hence it results in an improper library format issue.

      I have no idea why the library path is landing in that command, and how to fix it, so if anyone could gimme a few hints, I am available to test eventual patches

       

       

        Attachments

        1. BUILD.gn
          75 kB
        2. config.cache
          26 kB
        3. config.log
          366 kB
        4. config.opt
          1 kB
        5. config.status
          0.0 kB
        6. config.summary
          8 kB
        7. qt.log.tar.gz
          374 kB
        8. qt.log2.tar.gz
          655 kB
        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            michal Michal Klocek
            Reporter:
            longchair LongChair
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes