Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-65174

QT 5.9.3 does not link against libnss3.so in CentOS 7

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Done
    • Affects Version/s: 5.9.3
    • Fix Version/s: 5.9.4
    • Component/s: WebEngine
    • Labels:
      None
    • Environment:
      CentOS 7.4

      Description

      In CentOS 7 when I use the released QT 5.9.2 to build an application that uses QWebEngineView I am able to connect to pages using HTTPS without issue.  When I run the same application using the released QT 5.9.3 I get these error messages:

      [11863:11873:1213/090956.282474:ERROR:cert_verify_proc_openssl.cc(212)] X509 Verification error unable to get local issuer certificate : 20 : 1 : 4

      These symptoms have only been observed in CentOS 7 and were not reproduced in Ubuntu 14 or in Windows.

      I think this is because NSS is not being linked in QT 5.9.3 when it is for QT 5.9.2.

      When I checked what libQt5WebEngine.so.5 is linked against I see this for QT 5.9.2:

      # ldd /opt/Qt/5.9.2/gcc_64/./qml/QtWebEngine/../../lib/libQt5WebEngine.so.5 | grep nss
      {{ libnss3.so => /lib64/libnss3.so (0x00007fae78924000)}}
      {{ libnssutil3.so => /lib64/libnssutil3.so (0x00007fae786f6000)}}

      but for QT 5.9.3, I get no results.

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              • Assignee:
                qt_webengine_team Qt WebEngine Team
                Reporter:
                gyee Gary Yee
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes