Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-66620

Setting only sourceSize.height or sourceSize.width while leaving the other component 0 no longer shows the image in Qt 5.10

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Fixed
    • Affects Version/s: 5.10.1
    • Fix Version/s: 5.11
    • Labels:
      None
    • Environment:
      Qt 5.10

      Windows 10

      Description

      As per the docs, setting sourceSize.height on an Image element to a value while leaving sourceSize.width at 0 (or vice versa) should scale the image such that the configured height is used and the other value is scaled according to the image's aspect ratio. And this is also the behavior seen on Qt 5.9 and below. But with Qt 5.10, this no longer works. Leaving one component of sourceSize at 0 causes the image to not be shown at all.

       See attached test case project. When this run on Qt 5.9, it shows the help icon on the right. On Qt 5.10 it doesn't.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            yulong.bai Bai Yulong
            Reporter:
            burk_daniel_omicron Burkhard Daniel
            Votes:
            2 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes