Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-67160

EGLFS KMS dual screen setup not working ok for Qt Widget

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: P2: Important
    • Resolution: Unresolved
    • Affects Version/s: 5.9.3
    • Fix Version/s: None
    • Labels:
      None

      Description

      hello,

      i put together a small code snippet for QtCreator, to better showcase the issue i see in my dual-head setup with a Qt widget app running through EGLFS on a libMali.so/DRM/KMS setup on Allwinner A20 mainline based OS:

       https://github.com/aventuri/widgetMultiScreen

      the outcome is the wrong display of the two (yellow and red) rectangles with the code above only on the ext HDMI diplay. see:

      https://drive.google.com/open?id=1tGJxoBzBNn_wEhCi5mnI5a5zLSKIrAwX

      the puzzling issue is that if i comment out the w2.show() line:

      https://github.com/aventuri/widgetMultiScreen/blob/master/main.cpp#L3

      i can see (correctly) a single yellow screen on the primary LCD display.

      can someone point me toward better debugging? is a GDB step by step approach the best one?  the Qt stack is that huge..

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            lagocs Laszlo Agocs
            Reporter:
            aventuri aventuri
            Votes:
            2 Vote for this issue
            Watchers:
            6 Start watching this issue

              Dates

              Created:
              Updated:

                Gerrit Reviews

                There are no open Gerrit changes