Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-67218

Possible downgrade of MapBox GL plugin between 5.9.4 -> 5.9.5

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Done
    • Affects Version/s: 5.9.5
    • Fix Version/s: 5.9.5
    • Labels:
      None

      Description

      Qt 5.9.4 released with mapbox-gl-native version 8c1be4ec01ef46bf453856531ebf53b48ce3dbe7.

      Shortly after release branch was done, the change "Use custom namespace in QtLocation's earcut" https://codereview.qt-project.org/#/c/215890 in 5.9 branch backtracked a few revisions back to version 572822c8ca15be190b43afbf7f91d132e988bf21

      This downgraded version is now going into 5.9.5. Is this correct or did the change linked above erroneously downgrade the revision?

      Later on, as the downgraded mapboxgl change was integrated into 5.10 and up, it was noticed and bumped back to latest revision 8c1be4ec01ef46bf453856531ebf53b48ce3dbe7 for 5.10.1 release with change https://codereview.qt-project.org/#/c/219549/

      The latest openmapboxgl revision is in 5.11 presently. Are these ok or or one or the other wrong currently?

        Attachments

        For Gerrit Dashboard: QTBUG-67218
        # Subject Branch Project Status CR V

          Activity

            People

            Assignee:
            paangele Paolo Angelelli
            Reporter:
            gronoff Mikko Gronoff
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes