Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-67764

QDoc is build against libclang 4.0 while it should be using at least 6.0

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Done
    • Affects Version/s: 5.11
    • Fix Version/s: 5.11.0
    • Component/s: Build tools: qdoc
    • Labels:
      None
    • Environment:
      Windows
    • Commits:
      c5ddbdb86b837fcdd406d12e66d8193c991bdede

      Description

      It seems that on Windows libclang 6.0 is needed. Our CI is using version 4.0

      {quote}

      nierob@43 ~/d/qt5> git status
      On branch 5.11
      Your branch is up to date with 'origin/5.11'.
      ....
      nierob@43 ~/d/qt5> cat coin/provisioning/common/shared/sw_versions.txt
      libclang_version="4.0"

      {quote}

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            leenam Leena Miettinen
            Reporter:
            nierob Nierob
            Votes:
            0 Vote for this issue
            Watchers:
            7 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes