Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-68248

Installer complains about Xcode Version 5.0.0 missing if Xcode hasn't been launched before Qt installation

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Done
    • Affects Version/s: 5.9.5, 5.10.1, 5.11.0 RC 1
    • Fix Version/s: 5.11.0
    • Component/s: Packaging & Installer
    • Labels:
      None
    • Environment:
      MacOS 10.11, 10.12, 10.13

      Description

      When running the macOS Qt installer, immediately after the prompt to log in to Qt (which is successful) a following error is received if Xcode hasn't been launched once before running Qt installer.

      "You need to install Xcode version 5.0.0. Download Xcode from https://developer.apple.com/xcode."

      If Xcode is required to be launched before Qt installation the installer error message should refer to that instead of complaining about Xcode installation missing.

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              aksalova Akseli Salovaara
              Reporter:
              kileppal Kimmo Leppälä
              Votes:
              2 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes