Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-68477

debian stretch cannot build qdoc even with llvm-3.9-dev and clang.3.9-dev installed

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Out of scope
    • Affects Version/s: 5.11.0
    • Fix Version/s: None
    • Component/s: Build tools: qdoc
    • Labels:
      None
    • Environment:
      Debian Stretch and default apt repos.

      GCC 6.4.0 / MinGW-w64 5.0.3 / Windows 7 sp1

       

      Description

      QTBUG-68410

      like what I said, I tried couple of times recently. Linux Debian Stretch cannot build qdoc out of box even llvm-3.9-dev and clang-3.9-dev installed.

      and in the latest document, llvm/clang 3.9 should be good enough for qdoc. when I install llvm-3.9-dev and llvm-config actual named llvm-config-3.9, this might be the issue.

       

      my suggestion is a minimized clang should be integrated to qt source, like V8 as qtjsbackend for qt 5.0. and this still can improve qt tool chain like moc and qdoc, even qt-creator.

       

      I have already give up to make a complete qt build using GCC 6.4 mingw-w64 5.0.3 on windows. but it seems on linux qt cannot be built with qdoc either.

       

        Attachments

          Issue Links

          For Gerrit Dashboard: QTBUG-68477
          # Subject Branch Project Status CR V

            Activity

              People

              Assignee:
              docteam Qt Documentation Team
              Reporter:
              dext dexter
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes