Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-69203

"Enabling Translation" example should not use meta catalogs

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Fixed
    • Affects Version/s: 5.11, 5.13.1
    • Fix Version/s: 5.13.2
    • Component/s: Documentation
    • Labels:
      None
    • Platform/s:
      All
    • Commits:
      21d65d5c2dbfadb3e6dae0707f2ba6e0d4bb2c30

      Description

      Currently the first example showing how to use translations (http://doc.qt.io/qt-5/internationalization.html#enabling-translation) instructs to use the meta catalogs (qt_xx.qm) which were created to ease porting effort from Qt4.

      Problem with the meta catalogs are that they depend on translations for now deprecated modules (qtquick1, qtscript) that might not be installed in the system (QTBUG-69146), which causes loading of the translation to fail (which is also not checked in the example).

      Instead of the meta catalogs, the example should use the modularized translation files.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            leenam Leena Miettinen
            Reporter:
            sapiippo Samuli Piippo
            Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes