Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-70528

Qt Wayland doesn't build with old versions of libwayland

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Done
    • Affects Version/s: 5.12
    • Fix Version/s: 5.12.0 Beta 1
    • Component/s: QPA: Wayland
    • Labels:
      None
    • Platform/s:
      Linux/Wayland
    • Commits:
      ef3ddbeee40b9dddc2bc9754a5ba2f47a39874a7 (qt/qtwayland/5.12)

      Description

      We recently upgraded wayland.xml to 1.10, although we're supposed to support libwayland as old as 1.6

      This should have been fine, however having a newer version of wayland.xml than libwayland is only supported if only the core includes are used. I.e. wayland-client-core instead of wayland-client. Ditto for server.

      Consequently, libwayland doesn't currently build with libwayland 1.9 or older.

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              johanhelsing Johan Helsing
              Reporter:
              johanhelsing Johan Helsing
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes