Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-70784

qtwebengine depends on qtquickcontrols

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Done
    • Affects Version/s: 5.11.2
    • Fix Version/s: 5.12.0 Beta 3
    • Component/s: Build System
    • Labels:
      None
    • Platform/s:
      Linux/X11
    • Commits:
      b365b3853e85eb985f769a8b772cc1165bfe590c (qt/qt5/5.12)

      Description

      As soon as I do "configure -skip qtquickcontrols ..." the qtwebengine submodule is not build anymore.

      I would be surprised if this dependency is actually correct. Maybe it is because of some examples using quick controls 1, but as I have demos/tests also disabled it should not be necessary to build this deprecated module.

      Actually I would like to disable all Qt/Quick stuff beside the core parts of qtdeclarative for my build.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            michal Michal Klocek
            Reporter:
            uwe Uwe Rathmann
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes