Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-72789

tst_modelreplicatest failed

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reported
    • Priority: P2: Important
    • Resolution: Unresolved
    • Affects Version/s: 5.12
    • Fix Version/s: None
    • Component/s: Remote Objects
    • Labels:
    • Environment:
      macOS 10.12
    • Platform/s:
      macOS

      Description

      agent:2018/12/28 14:34:18 build.go:193: /Users/qt/work/qt/qtremoteobjects/tests/auto/modelreplica/target_wrapper.sh  ./tst_modelreplicatest -o /Users/qt/work/testresults/tests/auto/modelreplica177224671,xml -o -,txt
      agent:2018/12/28 14:34:18 build.go:193: ********* Start testing of ModelreplicaTest *********
      agent:2018/12/28 14:34:18 build.go:193: Config: Using QtTest library 5.12.0, Qt 5.12.0 (x86_64-little_endian-lp64 shared (dynamic) release build; by Clang 8.1.0 (clang-802.0.42) (Apple))
      agent:2018/12/28 14:34:18 build.go:193: PASS   : ModelreplicaTest::initTestCase()
      agent:2018/12/28 14:34:18 build.go:193: QWARN  : ModelreplicaTest::basicFunctions(non-templated enableRemoting) qt.remoteobjects: "localhost"  is not an IP address, trying to resolve it
      agent:2018/12/28 14:34:19 build.go:193: PASS   : ModelreplicaTest::basicFunctions(non-templated enableRemoting)
      agent:2018/12/28 14:34:19 build.go:193: QWARN  : ModelreplicaTest::basicFunctions(templated enableRemoting) qt.remoteobjects: "localhost"  is not an IP address, trying to resolve it
      agent:2018/12/28 14:34:19 build.go:193: PASS   : ModelreplicaTest::basicFunctions(templated enableRemoting)
      agent:2018/12/28 14:34:19 build.go:193: QWARN  : ModelreplicaTest::nullModel() qt.remoteobjects: "localhost"  is not an IP address, trying to resolve it
      agent:2018/12/28 14:34:19 build.go:193: QWARN  : ModelreplicaTest::nullModel() qt.remoteobjects: QRemoteObjectSourceBase: Cannot replicate a NULL object "tracks"
      agent:2018/12/28 14:34:19 build.go:193: FAIL!  : ModelreplicaTest::nullModel() 'replica->waitForSource(100)' returned FALSE. ()
      agent:2018/12/28 14:34:19 build.go:193:    Loc: [tst_modelreplicatest.cpp(99)]
      agent:2018/12/28 14:34:19 build.go:193: PASS   : ModelreplicaTest::cleanupTestCase()
      

      This fail happened on a personal instance testing new CI infra. No testresult link available.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            bstottle Brett Stottlemyer
            Reporter:
            tosaraja Tony Sarajärvi
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:

                Gerrit Reviews

                There are no open Gerrit changes